TriniTuner.com  |  Latest Event:  

Forums

The Official CS Lancer Thread!

Mitsu Lancer, Evo, GSR, MIVEC, 4G**, GDI, Galant, Outlander, L200 Sportero/Triton etc.

Moderator: 3ne2nr Mods

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: The Official CS Lancer Thread!

Postby Jade_Inc. » June 4th, 2016, 8:14 pm

Hey, what could cause the left back of my car to be lower than the right back? I changed shock and spring and it's the same... it's also cutting on the outside too... CS3

Advertisement
User avatar
BoostJunkieXL
Sweet on this forum
Posts: 336
Joined: August 31st, 2008, 9:39 pm

Re: The Official CS Lancer Thread!

Postby BoostJunkieXL » June 16th, 2016, 1:08 pm

tuners i need some assistance...i was driving one day and the car started jerking alot. upon inspection i realized my #4 coil blew. so i changed it..then couple days after #1...changed #1 #2 #2 coildpacks then....car worked fine and due to this 80kmph limit i dont drive hard much.....but i recently passed on a long straight and when i opened the throttle..car started jerking and backfiring bubbling like a wrx loss of power...checked coilpacks and plugs...theyre still good :/...no issued when driving at normal speeds or idling...only when i try to drive lil hard....any insight will be greatly appreciated.

nissan4life
Chronic TriniTuner
Posts: 507
Joined: April 10th, 2011, 1:53 pm
Location: 3NE2NR is my LIFE

Re: The Official CS Lancer Thread!

Postby nissan4life » June 16th, 2016, 3:06 pm

Boostjunkie what plugs are you using? sounds like another bad coil or plugs
I once tried the iridium hot plug with my gdi and in a couple of months i changed two coil packs, since then i have gone back to the normal double tip NGK 5euc.
The jerking and lost of power should be a result of the ecu not getting proper readings from coils, is there a cel went his happens?

You do know cvt tranmissions use a gear ratio to transfer power and not meant to be accelerated hard/fast from a complete stop.

User avatar
Kronik
12 pounds of Boost
Posts: 2246
Joined: July 23rd, 2004, 9:37 pm
Location: Central
Contact:

Re: The Official CS Lancer Thread!

Postby Kronik » June 16th, 2016, 8:08 pm

I had that same problem, thought was the plugs. Turns out my radiator had a small leak and it sent up the temperature slightly, barely noticeable on the gauge, but when i press out it heated up the plug electrode so fast they got slightly 'warped' (for lack of a better word) enough that it the caused the stem to blow. Changed radiator to 3 core aluminum and same old plugs working normal. Have some new plugs on standby though.

SUPERMAN NY
Riding on 13's
Posts: 11
Joined: June 21st, 2011, 7:25 am

Re: The Official CS Lancer Thread!

Postby SUPERMAN NY » June 22nd, 2016, 11:01 pm

Hi guys! can u pls assist me in locating/repairing this issue thanks! the white piece was broken up when i unscrewed it. Can i get that part or will i have to buy the whole thing?
Attachments
IMG_4975.JPG

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8233
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: The Official CS Lancer Thread!

Postby BrotherHood » June 23rd, 2016, 11:15 am

SUPERMAN NY wrote:Hi guys! can u pls assist me in locating/repairing this issue thanks! the white piece was broken up when i unscrewed it. Can i get that part or will i have to buy the whole thing?

Check Diamond Motors. Got my mine there about about two years ago for around $100. That's for the plastic cap itself.

nissan4life
Chronic TriniTuner
Posts: 507
Joined: April 10th, 2011, 1:53 pm
Location: 3NE2NR is my LIFE

Re: The Official CS Lancer Thread!

Postby nissan4life » June 23rd, 2016, 1:36 pm

Wasnt there a fix for this already?
check the link
http://trinituner.com/v4/forums/viewtop ... start=9990

SUPERMAN NY
Riding on 13's
Posts: 11
Joined: June 21st, 2011, 7:25 am

Re: The Official CS Lancer Thread!

Postby SUPERMAN NY » June 24th, 2016, 8:54 am

Thanks guys!

soundboi86
Street 2NR
Posts: 54
Joined: June 10th, 2010, 10:30 am

Re: The Official CS Lancer Thread!

Postby soundboi86 » July 13th, 2016, 7:10 pm

Good day tuners. Im new to this thread. I own a cs3 lancer and i wanna know were can i get a gearbox to buy. If u guys can help me out will be much appriciated

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 20th, 2016, 9:34 am

Hey,
A few days now, I'm driving and my temperature just keeps going up once im in traffic. I checked the fans and they are working. This morning I started the car and put on the AC, The both fans came on and after the temperature reached half, they cut off. Are they supposed to stop or does it have to keep on working once the AC is on? CS3 4G18

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8233
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: The Official CS Lancer Thread!

Postby BrotherHood » July 20th, 2016, 9:40 am

Once AC on fans supposed to stay on.
Sounds like your fan controller giving trouble.

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 20th, 2016, 10:45 am

I wonder if there is a fix, other than buying a new controller

User avatar
Kronik
12 pounds of Boost
Posts: 2246
Joined: July 23rd, 2004, 9:37 pm
Location: Central
Contact:

Re: The Official CS Lancer Thread!

Postby Kronik » July 20th, 2016, 11:07 am

Fellas, I looking for a driver side mirror (non powered folding), and a evaporator with the whole box and thing for under the dashboard. Also looking for some other upholstery parts like door skins and fabric back seats, but those are secondary items. Need the mirror and evaporator priority

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8233
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: The Official CS Lancer Thread!

Postby BrotherHood » July 20th, 2016, 11:40 am

Kronik wrote:Fellas, I looking for a driver side mirror (non powered folding), and a evaporator with the whole box and thing for under the dashboard. Also looking for some other upholstery parts like door skins and fabric back seats, but those are secondary items. Need the mirror and evaporator priority

Check Mohammed's Auto Parts in the bamboo. Located just after the exit of Grand Bazaar unto the UBH southbound.









Jade_Inc. wrote:I wonder if there is a fix, other than buying a new controller

You checked the radiator for leaks? Any residue on the top tank?
Seems most likely that your fans not coming on as they should since you say the temp. goes up when in traffic. Car isn't moving for breeze to pass through. If no leaks on radiator then it's the fan controller (or water pump sticking).

There isn't any fix that I am aware of for that fan controller. You will have to buy one. I bought one from Amazon. Way cheaper than what is available locally. It wasn't OEM but working very good for almost a year now. Check this link https://www.amazon.com/Partsam-Cooling- ... +1355A-124

Apparently the Mazda 6 around the same years use the same fan controller.

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: RE: Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 20th, 2016, 9:34 pm

BrotherHood wrote:
Kronik wrote:Fellas, I looking for a driver side mirror (non powered folding), and a evaporator with the whole box and thing for under the dashboard. Also looking for some other upholstery parts like door skins and fabric back seats, but those are secondary items. Need the mirror and evaporator priority

Check Mohammed's Auto Parts in the bamboo. Located just after the exit of Grand Bazaar unto the UBH southbound.









Jade_Inc. wrote:I wonder if there is a fix, other than buying a new controller

You checked the radiator for leaks? Any residue on the top tank?
Seems most likely that your fans not coming on as they should since you say the temp. goes up when in traffic. Car isn't moving for breeze to pass through. If no leaks on radiator then it's the fan controller (or water pump sticking).

There isn't any fix that I am aware of for that fan controller. You will have to buy one. I bought one from Amazon. Way cheaper than what is available locally. It wasn't OEM but working very good for almost a year now. Check this link https://www.amazon.com/Partsam-Cooling- ... +1355A-124

Apparently the Mazda 6 around the same years use the same fan controller.

I changed water pump approximately a year ago, I don't think d radiator has any leaks also, even tho I top up my reservoir once week cuz only that water goes down.
I'll try to run some test on the controller.
I'm searching for an engine so I'll see how cheap I can get the controller for one time

User avatar
Parvin
I LUV THIS PLACE
Posts: 1092
Joined: September 20th, 2006, 12:42 am

The Official CS Lancer Thread!

Postby Parvin » July 20th, 2016, 10:10 pm

I believe that if you have to keep topping up the reservoir as often as you do then you're losing coolant/water ... So there's a leak somewhere in the cooling system.

Possible blown head gasket?

You should get it checked out asap.

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8233
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: The Official CS Lancer Thread!

Postby BrotherHood » July 21st, 2016, 12:50 am

Sometimes a month or more passes before I even check that coolant reservoir. Topping up every week means you are losing an excessive amount of coolant as Parvin said. Under normal conditions you shouldn't really have to top up at all.
Check the bottom hoses: the main big radiator hose and two smaller ones that cools the transmission.
And I see you said water. Hope you use only coolant and a good/decent one too. Not the $20 Champion brand which is like water with green colouring.

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 21st, 2016, 5:47 am

Ohhhh...I more believe it's a blown head gasket cuz it over heated twice... first, the cap on the radiator wasn't tightened properly and all the water came.out.. the next was bcuz of the thermostat... when I change the engine, hopefully weekend, I would use coolant.
Thanks guys

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8233
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: The Official CS Lancer Thread!

Postby BrotherHood » July 21st, 2016, 8:02 am

What engine you going with and what you changing from?

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: RE: Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 21st, 2016, 8:32 am

BrotherHood wrote:What engine you going with and what you changing from?

I'm going back with the original engine...4G18...I have the same engine but its burning a little oil... my only reason for changing

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8233
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: The Official CS Lancer Thread!

Postby BrotherHood » July 21st, 2016, 9:10 am

Yes mine start to burn some oil and my tappets making a lil noise now. Mileage very high too. 250K

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 21st, 2016, 9:41 am

My mileage is 318k ... never had a problem with it since I bought it

User avatar
daniel135
Chronic TriniTuner
Posts: 513
Joined: November 16th, 2008, 10:13 am
Contact:

Re: The Official CS Lancer Thread!

Postby daniel135 » July 21st, 2016, 9:47 am

Mine was burning a little oil at 120k mileage. We did a full engine overhaul, rings, bearings, seals everything. Bought the parts diamond motors when they had the 50% sale. Not sure if the previous owner used to beat up on d car, seeing that mine is manual

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: RE: Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 21st, 2016, 10:44 am

daniel135 wrote:Mine was burning a little oil at 120k mileage. We did a full engine overhaul, rings, bearings, seals everything. Bought the parts diamond motors when they had the 50% sale. Not sure if the previous owner used to beat up on d car, seeing that mine is manual

Well, if anything happens to one, I'll always have one on d ground ready to doctor it

User avatar
daniel135
Chronic TriniTuner
Posts: 513
Joined: November 16th, 2008, 10:13 am
Contact:

Re: The Official CS Lancer Thread!

Postby daniel135 » July 21st, 2016, 10:48 am

Ha ha yea. Boost it like me.lol

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 21st, 2016, 12:33 pm

I might just do that once d funds available

User avatar
BrotherHood
TriniTuner 24-7
Posts: 8233
Joined: October 20th, 2010, 2:41 pm
Location: Bringing HID & LED to a location near you! 355-3165. 704-5442 (WhatsApp).

Re: The Official CS Lancer Thread!

Postby BrotherHood » July 21st, 2016, 1:00 pm

manual or cvt Jade?

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: RE: Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 21st, 2016, 1:42 pm

BrotherHood wrote:manual or cvt Jade?

Cvt
Would the next 4g18 engine work with my original brain an harness?

User avatar
daniel135
Chronic TriniTuner
Posts: 513
Joined: November 16th, 2008, 10:13 am
Contact:

Re: RE: Re: RE: Re: The Official CS Lancer Thread!

Postby daniel135 » July 21st, 2016, 1:46 pm

Jade_Inc. wrote:
BrotherHood wrote:manual or cvt Jade?

Cvt
Would the next 4g18 engine work with my original brain an harness?

Yes it will work back. You can even use the 4g15 sohc engine. Just use back you intake and exhaust manifold. Because its gonna be a lil tuff to locate a 4g18

User avatar
Jade_Inc.
Chronic TriniTuner
Posts: 680
Joined: February 18th, 2010, 7:18 pm

Re: The Official CS Lancer Thread!

Postby Jade_Inc. » July 21st, 2016, 1:59 pm

I heard 4g15 does give Rel trouble so I don't wanna go down da road... I'm going hunting in penal tomorrow and maybe d bamboo

Advertisement

Return to “MITSUBISHI”

Who is online

Users browsing this forum: No registered users and 6 guests