TriniTuner.com  |  Latest Event:  

Forums

Search found 491 matches

by nissan4life
March 5th, 2012, 9:33 pm
Forum: MITSUBISHI
Topic: o2 sensor
Replies: 15
Views: 3144

Re: o2 sensor

jus sharing my lil 2cents with everyone.. from the first post you can see the problem i had. I came across a check light and came up with a code po425 which was making my car run lean and i thought was a oxygen sensor,but because the previous owner removed the cat below the car and removed the senso...
by nissan4life
February 14th, 2012, 3:47 pm
Forum: MITSUBISHI
Topic: 2002 LANCER Help needed asap
Replies: 2
Views: 698

Re: 2002 LANCER Help needed asap

dred i had a b13 beast original condition i miss tha car buh anyway i kow about the 2 sensors,got some infor from a fellow tuner The problem im having is that the previous owner removed the cat below the car and left no track of the rear o2 wire harness,so i really needed to know where does the o2 s...
by nissan4life
February 9th, 2012, 8:31 am
Forum: MITSUBISHI
Topic: o2 sensor
Replies: 15
Views: 3144

Re: o2 sensor

thats the exact code im getting,i too have also changed the o2 on the exhaust in the front and believed that i had to change the one in the back to solve this problem,only to realise there is nothing there,i want to believe the 2pin connector would have led to the space on the body of the car and co...
by nissan4life
February 8th, 2012, 7:36 pm
Forum: MITSUBISHI
Topic: o2 sensor
Replies: 15
Views: 3144

Re: o2 sensor

idlemind just got out below the car,there is no wires running below the car,which i found strange,looked like the previous owner removed the catalytic convertor and that is why the check light keeps coming on. What i did find though was a small piece of rubber like a seal below the car,followed it b...
by nissan4life
February 8th, 2012, 1:05 pm
Forum: MITSUBISHI
Topic: o2 sensor
Replies: 15
Views: 3144

Re: o2 sensor

Thanks alot man,will look into dis afternoon and keep u posted
knowledge really is power.....
by nissan4life
February 8th, 2012, 10:01 am
Forum: MITSUBISHI
Topic: o2 sensor
Replies: 15
Views: 3144

Re: o2 sensor

yes idlemind i do kinda new to the lancer experience and a smart man sold me his car, to only realize in the first day of driving the service light came on. I got it scanned and its showing me the downstream sensor at a constant signal,so the mechanic told me the second o2 sensor needs to be changed...
by nissan4life
February 7th, 2012, 1:03 pm
Forum: MITSUBISHI
Topic: The Official CS Lancer Thread!
Replies: 14611
Views: 1031858

Re: CS Lancer!

does any one know how many o2 sensors are on the 2002 lancer?
by nissan4life
February 7th, 2012, 1:02 pm
Forum: MITSUBISHI
Topic: o2 sensor
Replies: 15
Views: 3144

o2 sensor

can anyone say how many oxygen sensors are on the 2002 lancer
im get a check engine light and the code is stating it the catalytic temperature sensor
have already changed the one on the front of the car,by exhaust manifold,but the damn light still on.
by nissan4life
February 6th, 2012, 12:08 pm
Forum: MITSUBISHI
Topic: 2002 LANCER Help needed asap
Replies: 2
Views: 698

2002 LANCER Help needed asap

Good day all mitsi lovers kinda new to the lancer experience.i bought a 2002 cedia had it for at least a week before the check light engine came on. Had the light checked out and the code said the the catalytic temperature sensor was bad, the mechanic told me was the o2 sensor,so i got one and had t...
by nissan4life
October 18th, 2011, 12:07 pm
Forum: NISSAN
Topic: GA15/16 burning oil
Replies: 20
Views: 5863

Re: GA15/16 burning oil

Thanks kiran-tek i actually got it at motorist,its called a gasket rocker valve the part number is 13271-4m501 for those interested took out my valve cover,slapped in the new one which was located below the valve cover, tightened everything back up and i was back in a gear no smoke since. This is a ...
by nissan4life
September 27th, 2011, 3:05 pm
Forum: NISSAN
Topic: GA15/16 burning oil
Replies: 20
Views: 5863

Re: GA15/16 burning oil

yea fellas got a b13 with a ga16de gettin a lil smoke and want to believe this is my problem can you say where this part was bought? i checked mathuras and they are stating that there is no such gasket under the valve cover i aint think everyone on this forum wrong,so is either they dumb,deaf or jus...

Go to advanced search